Daily FTP & Portal Reports Delayed - 17th February 2026

Incident Report for Caribbean Credit Card Corporation

Resolved

Dear Client,

We advise that the reports were made available for viewing and downloading.

We thank you for your patience and understanding.

Regards,
Posted Feb 18, 2026 - 10:56 GMT-04:00

Update

Good day Client

We advise that the FTP reports are available,

The team continue to work on uploading the Portal reports.

A further update will be provided once the Portal reports are available,

Thnaks for your patience in this matter.

Kindest Regards,
Posted Feb 17, 2026 - 15:06 GMT-04:00

Update

We are continuing to monitor for any further issues.
Posted Feb 17, 2026 - 09:45 GMT-04:00

Monitoring

Dear Client

We advise that the FTP & Portal reports for February 16th, 2026 are delayed. The team is currently working to provide the reports soonest.

A further update will be provided once the reports become available.

We sincerely apologize for the delay and appreciate your understanding.

Kindest Regards,
Posted Feb 17, 2026 - 08:44 GMT-04:00
This incident affected: Daily Reports (Client Portal Reports, FTP Reports).