Delayed Start of Day - December 15th 2025

Incident Report for Caribbean Credit Card Corporation

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 07:52 GMT-04:00

Identified

Dear Participants,

Please be advised that the end-of-day process for Monday, December 15, 2025, was successfully completed on the disaster recovery site.

Our team is actively working to resolve the issue affecting the production environment. Until further notice, all processing will continue to be handled through the disaster recovery site.

We sincerely apologize for any inconvenience this may cause and appreciate your continued patience and cooperation during this time.

Regards,
ECACH Operator
Posted Dec 16, 2025 - 07:22 GMT-04:00

Update

Dear Participants,

Kindly be advised that Settlement times for VIP Session and Session 4 have been extended to 6:00 pm for today 15th December 2025. This is for Settlement purposes only and NO VIP items should be submitted after 3:30pm.

All end of session reports will be available upon completion of settlement .

Please be guided accordingly.

Regards
ECACH Operator
Posted Dec 15, 2025 - 15:43 GMT-04:00

Update

Dear Participants,

Kindly be advised that Settlement times for VIP Session and Session 4 have been extended to 6:00 pm for today 15th December 2025. This is for Settlement purposes only and NO VIP items should be submitted after 3:30pm.

All end of session reports will be available upon completion of settlement .

Please be guided accordingly.

Regards
ECACH Operator
Posted Dec 15, 2025 - 15:40 GMT-04:00

Update

Dear Participants,

Please be advised that on the advice of the Operator, the ECCB and ECACHSI has given permission to invoke BCP Operations on the ECACH platform. As a result BCP Procedures has been invoked for today 15th December 2025.

Operations have been transferred to the Disaster Recovery Site.

Please note the URLS listed below to access the Disaster Recovery Environment:

HTTP Server Configured (Requires the use of PKI client, token and certificate)

DR ACH https://10.4.2.112/ach/Login.jsp

Please be guided accordingly.

ECACH Operator
Caribbean Credit Card Corporation
Posted Dec 15, 2025 - 08:41 GMT-04:00

Update

Dear Participants,

We continue to investigate an issue affecting Start of Day for today 15th December 2025.
All relevant teams are engaged and working on resolving this issue.

Further updates will be provided as they become available.

We apologize for any inconvenience.

Regards,
ECACH Operator
Posted Dec 15, 2025 - 08:28 GMT-04:00

Investigating

Dear Participants,

Please be advised that we are investigating an issue that has delayed the Start of Day for today, December 15th, 2025.

Further updates will be provided as they become available.

We apologize for any inconvenience caused.

ECACH Operator
Posted Dec 15, 2025 - 07:36 GMT-04:00
This incident affected: ECACH (Clearing Session).