Service Disruption - Internet Merchants and POS transaction Porcessing 11th February 2026

Incident Report for Caribbean Credit Card Corporation

Resolved

Dear Client

We advise that the issue has been resolved and the services have been restored.

Thank you for your patience on this matter.

Regards
Posted Feb 11, 2026 - 14:38 GMT-04:00

Investigating

Dear Client,

We are investigating service interruptions that have impacted the processing of Point of Sale and e-commerce transactions; all teams are currently engaged in resolving the issue.

A further update will be provided.

We sincerely apologize for the inconvenience.

Regards,

Caribbean Credit Card Corporation Limited
Posted Feb 11, 2026 - 13:57 GMT-04:00
This incident affected: Acquiring Services (DialUp Merchant Authourisation, Internet Merchant Authourisation, Ecommerce Merchants).