Client Portal Reports Delayed-April 7th, 2026

Incident Report for Caribbean Credit Card Corporation

Resolved

Good day Client,

Thank you for your patience. Kindly advise that Client Portal reports are now available.

We apologize for any inconveniences caused.

Sincerely,
Posted Apr 07, 2026 - 13:37 GMT-04:00

Identified

Good day Client,

Please be advised that the Portal Reports for April 7th, 2026, are delayed. The relevant teams are currently working to provide the reports.

A further update will be shared once the reports become available.

Please accept our apologies for the inconvenience.

Kindest regards,
Posted Apr 07, 2026 - 09:23 GMT-04:00
This incident affected: Daily Reports (Client Portal Reports).