Service Inturuption ECACH Production Environment - 15th December 2025

Incident Report for Caribbean Credit Card Corporation

Resolved

Dear Participants,

Thank you for your patience and understanding.

Please be advised that operations have been restored to ECACH Production environment. Kindly restart your gateways and confirm connectivity by 8:30 A.M.

Kind regards,

ECACH Operator
Caribbean Credit Card Corporation
Posted Dec 17, 2025 - 07:10 GMT-04:00

Identified

Dear Participants,

Please be advised that the end-of-day process for Monday, December 15, 2025, was successfully completed on the disaster recovery site.

Our team is actively working to resolve the issue affecting the production environment. Until further notice, all processing will continue to be handled through the disaster recovery site.

We sincerely apologize for any inconvenience this may cause and appreciate your continued patience and cooperation during this time.

Regards,
ECACH Operator
Posted Dec 16, 2025 - 07:52 GMT-04:00
This incident affected: ECACH (Clearing Session, Website Access, Settlement, Email Alerts, Reporting).