We advise that the Merchant Statements for April 27th 2026 are now available on the FTP.
Thanks for your patience and understanding.
Kindest Regards,
Posted Jul 28, 2026 - 12:34 GMT-04:00
Identified
Good day Client
Please be advised that the Merchant Statements for July 27, 2026 are currently delayed. Our relevant support teams are actively investigating the issue and working to provide the Merchant Statements as quickly as possible.
We will provide a further update as soon as the statements become available.
We sincerely apologize for any inconvenience this delay may cause and appreciate your patience and understanding
Kindest Regards,
Posted Jul 28, 2026 - 11:31 GMT-04:00
This incident affected: Daily Reports (Merchant Statements).