Thank you for your patience, we are please to advise that the AMEX reports are now available on the Card Portal.
We apologizze for any inconvenienced caused in theis matter.
Sincerely,
Posted Feb 11, 2026 - 14:51 GMT-04:00
Investigating
Dear Client,
We advise that we are currently investigating an issue that has delayed the generation of AMEX reports for availability on the Card Portal. The relevant teams are currently engaged in resolving the issue and an update will be provided as soon as it is resolved.
We apologize for any inconvenience caused and appreciate your patience an understanding.
Sincerely,
Posted Feb 11, 2026 - 13:04 GMT-04:00
This incident affected: Daily Reports (Client Portal Reports).