ACH Email Alerts Service Interruption 22nd January 2026

Incident Report for Caribbean Credit Card Corporation

Resolved

Dear Participant,

Further to our previous notice regarding the interruption of the email alert service, please be advised that the issue has now been resolved.

Email alerts are now stable and functioning as expected.

We thank you for your patience and understanding while our teams worked to restore the service.

Kind regards,
ECACH Operator
Posted Feb 13, 2026 - 09:00 GMT-04:00

Update

Dear Participant,

Please be advised that we are still experiencing an interruption the email alert service, all teams are actively engaged and working on providing a resolution.

Participants are reminded to regularly monitor VIP items throughout the VIP Session.

Further update will be shared as soon as it becomes available.

ECACH Operator
Posted Jan 23, 2026 - 09:05 GMT-04:00

Identified

Dear Participant,

Please be advised that we are currently experiencing an interruption the email alert service. The relevant technical teams have been engaged, and further updates will be communicated in due course.

Participants are advised to regularly monitor VIP items throughout the VIP Session.

We apologize for any inconvenience caused and appreciate you patience.

ECACH Operator
Posted Jan 22, 2026 - 11:21 GMT-04:00
This incident affected: ECACH (Email Alerts).