Delayed Start of Day - 30 July 2026

Incident Report for Caribbean Credit Card Corporation

Monitoring

Dear Participants,

Please be advised that operations have been restored to ECACH Production environment.

Thank you for your patience and understanding.

Kind regards,

ECACH Operator
Caribbean Credit Card Corporation
Posted Aug 02, 2026 - 14:38 GMT-04:00

Update

Dear Participants,

Please be advised that the end-of-day process for today, July 31, 2026, was successfully completed on the disaster recovery site.

Our team is continuing to work diligently to resolve the issue affecting the production environment. Until further notice, all processing will continue to be conducted through the disaster recovery site.

We sincerely apologize for any inconvenience this may cause and appreciate your continued patience and cooperation during this time.

Regards,
ECACH Operator
Posted Jul 31, 2026 - 22:00 GMT-04:00

Update

Dear Participants,

Please be advised that the end-of-day process for Thursday, July 30, 2026, was successfully completed on the disaster recovery site.

Our team is actively working to resolve the issue affecting the production environment. Until further notice, all processing will continue to be handled through the disaster recovery site.

We sincerely apologize for any inconvenience this may cause and appreciate your continued patience and cooperation during this time.

Regards,
ECACH Operator
Posted Jul 31, 2026 - 07:46 GMT-04:00

Update

Dear Participants,

Kindly be advised that Settlement times for VIP Session and Session 4 have been extended to 4:30 pm for today, July 30, 2026. This is for Settlement purposes only and NO VIP items should be submitted after 3:30pm.

All end of session reports will be available upon completion of settlement .

Please be guided accordingly.

ECACH Operator
Posted Jul 30, 2026 - 14:20 GMT-04:00

Update

Dear Participants,

Please be advised that the connectivity issues following the activation of Business Continuity Plan (BCP) operations and failover to the Disaster Recovery (DR) environment have been resolved.

Participants can now connect to the system.

Thank you for your patience and cooperation.

ECACH Operator
Posted Jul 30, 2026 - 13:03 GMT-04:00

Update

Dear Participants,

Please be advised that following the activation of Business Continuity Plan (BCP) operations and the failover to the Disaster Recovery (DR) environment, participants are currently experiencing connectivity issues.

Our technical teams are actively investigating the matter and are working to restore connectivity as quickly as possible.

We will provide further updates as more information becomes available.

We apologize for any inconvenience and appreciate your patience and cooperation.

ECACH Operator
Caribbean Credit Card Corporation
Posted Jul 30, 2026 - 11:53 GMT-04:00

Update

Dear Participants,

Please be advised that, on the advice of the ECACHSI, permission has been granted to invoke Business Continuity Plan (BCP) operations on the ECACH platform. Accordingly, BCP procedures have been invoked for today, 30 July 2026.

Operations have been transferred to the Disaster Recovery (DR) site.

Please use the URL below to access the Disaster Recovery environment:

HTTP Server Configuration (requires the use of a PKI client, token, and certificate)

DR ACH: https://10.4.2.112/ach/Login.jsp

Please be guided accordingly.

ECACH Operator
Caribbean Credit Card Corporation
Posted Jul 30, 2026 - 11:16 GMT-04:00

Update

Dear Participants,

We continue to experience issues with the ECACH Production Environment and are working closely with our vendors to resolve them as soon as possible.

Thank you for your continued patience and understanding.

Kind regards,

ECACH Operator
Posted Jul 30, 2026 - 09:48 GMT-04:00

Update

Dear Participants,

As part of our efforts to resolve the current issue affecting the ECACH, we will be performing a restart of the ECACH Production Environment. As a result, the ECACH Production Environment will not be available until further notice.

Thank you for your understanding. We appreciate your patience.

ECACH Operator
Posted Jul 30, 2026 - 07:38 GMT-04:00

Investigating

Dear Participant,

We advise that Start of Day for today, July 30, 2026 on the ECACH Production Environment is delayed. The relevant teams are engaged and an update will be provided as soon as it becomes available.

We apologize for any inconvenience caused and appreciate you patience in this matter.

ECACH Operator
Posted Jul 30, 2026 - 07:23 GMT-04:00
This incident affects: ECACH (Clearing Session, Website Access, Settlement, Reporting).