4Cs Compliance Network Upgrade - April 17 2026

Scheduled for Apr 17, 00:00 - 04:00 GMT-04:00

Update

Dear Client,

Please note that the emergency upgrade to our Debit Card Authorisation System (IST) was completed on Sunday, 12 April 2026.

Best regards,
Posted Apr 13, 2026 - 09:20 GMT-04:00

Update

Important Notice: Change to Annual Compliance Upgrade Schedule

Dear Client

Please note the following important update to our Annual Compliance Upgrade, scheduled for 17 April 2026.

An emergency upgrade to our Debit Card Authorisation System (IST) has been scheduled for Sunday, 12 April 2026. This upgrade will replace the IST component only of the Annual Compliance Upgrade. Details of the impacted services are outlined below.

Importantly, please note that the Card Management System (CMS) upgrade, affecting Credit Card Authorisations and Card Inquiry services, will proceed as originally scheduled on Friday, 17 April 2026.

Impact of the IST Upgrade – Sunday, 12 April 2026

Based on current estimates, the expected downtime will be approximately 2–3 hours, commencing at 1:00 a.m. and ending at 4:00 a.m.

During this period, acquiring and issuing services will be unavailable as follows:

4Cs Clients Acquiring Services POS & ATM) (excluding Onus ATM Activity and CyberSource)

4Cs Debit Routing Service- 4Cs Clients International Debit Cards used at 4Cs merchants and international merchants

4Cs Credit Card Issuing Service- 4Cs Clients Credit Cards used at 4Cs-merchants and international merchants

Compliance Upgrade Impact of the Card Management System – Friday, 17 April 2026

Based on vendor estimates, downtime will be approximately four (4) hours, commencing at 12:00 a.m. and ending at 4:00 a.m.

During this period, the following services will be unavailable:

Credit Card Authorisations and Card Inquiry services:
(12:00 a.m. – 4:00 a.m.)

We thank you for your understanding and continued support.

Should you have any questions, please contact our client services team.

Kindest Regards,
Posted Apr 09, 2026 - 10:00 GMT-04:00

Scheduled

Dear Client

Please be advised that the Caribbean Credit Card Corporation Ltd. will be performing the April Visa/MasterCard Compliance Upgrade of its Card Management System on Friday 17 April 2026. Based on estimates from our vendors, downtime would be approximately four (4) hours, commencing at 12 a.m. and ending at 4:00 a.m. During downtime, services will be unavailable as follows:

1. Credit Card Authorizations – approximately 4 hours (12:00 am to 4:00 a.m.)
2. Merchant Acquiring and International Debit Cards – approximately 2 hours (1:00 a.m. to 3:00 a.m.)
3. Shared Switch (ATM and International Debit Cards) – approximately 4 hours (12:00 a.m. to 4:00 a.m.)

Please feel free to share wit us, any additional recipients to be included on the April 2026 Compliance notifications for your institution.

Sincerely,
CARIBBEAN CREDIT CARD CORPORATION LTD.
Posted Mar 26, 2026 - 10:04 GMT-04:00
This scheduled maintenance affects: Acquiring Services (DialUp Merchant Authourisation, Internet Merchant Authourisation, ATM Acquiring, Ecommerce Merchants), Issuing Services (Cardholder Authourisation), and Shared Switch (Authourisation).