Delayed Clearing Settlement Session 4 and VIP- 17th December 2025

Incident Report for Caribbean Credit Card Corporation

Resolved

Dear Participant,

Please be advised that Settlement for Session 4 has ended, and end of session reports are available.

Thank you for your patience. We apologize for any inconvenience caused.

ECACH Operator
Posted Dec 18, 2025 - 08:48 GMT-04:00

Monitoring

Dear Participants,

Please be advised that the Settlement for Session VIP and Session 4 for today, 17th December, 2025, on the ECACH Production Environment is delayed. The relevant teams are engaged and working to resolve the issue, and updates will be provided when they become available.

Affected operations:

Unable to access End of Session 4 and VIP reports


We apologize for any inconvenience caused.

ECACH Operator
Caribbean Credit Card Corporation
Posted Dec 17, 2025 - 16:14 GMT-04:00
This incident affected: ECACH (Clearing Session, Settlement, Reporting).